Breaking change: login.ibiblio.org SSH key fingerprint changed

Following are the new host key fingerprints for login.ibiblio.org. Below that more info.

2048 SHA256:LcVOoQc3NvJsS25n2c+rVAO4TSX/cDMOdRyF427ZhNM no comment (RSA)
+---[RSA 2048]----+
|        o *  . *=|
|         X +. B o|
|        . X. =.B.|
|         X .+oBoE|
|        S *.+o.O.|
|         o o  =oo|
|             o  o|
|            .   .|
|             ... |
+----[SHA256]-----+
256 SHA256:23BTJIdynemS9A1JivKQJjmtdnYTjqv9jqittWLRqXw no comment (ECDSA)
+---[ECDSA 256]---+
|          .+++   |
|     o ...+=*    |
|    + * o+.+.o   |
|     = * .o.o .  |
|   .o.+ S o.     |
|  ..oo o * .     |
| . o. . . .      |
|  =oE= .         |
| .o== ooo        |
+----[SHA256]-----+
256 SHA256:WXhqk0T3eZCLlYaZ+WELvZFX7YSjFLRsaXs+shHB4B0 no comment (ED25519)
+--[ED25519 256]--+
|        . oBE= oo|
|       . +**%*+ o|
|        o +O%O.+ |
|       . *.o*+  .|
|        S   o .  |
|       . .   +   |
|            o o  |
|             + . |
|            .    |
+----[SHA256]-----+

If you have been using login2.ibiblio.org to manage your collection, there’s nothing to change.

The host that was serving login.ibiblio.org has been replaced. If for some reason you do not have access and believe that you should, you can reply here and a staff member will open a private ticket using the same email address you used for your account here. You don’t need to give any more background than what collection you manage. For example: “Hi, I manage the foobar collection, and I can’t seem to log in now. Please help.”

Before doing that, please check the following:

  • Did you reset the key fingerprints for login.ibiblio in your ssh or sftp client?
  • Did you check that you are using the username associated with your ibiblio collection and not some other account?
  • If you have been using login2.ibiblio.org to manage your collection, did you try just continuing to use that?

If none of those work, let us know.

EDITING TO ADD:

To clarify, the name “login.ibiblio.org” used to be an alias for the host login1, and is now an alias for the host login2. We would still prefer if people use the login.ibiblio.org name for now.

Hi! kelly@ibiblio.org here. I manage the Paul Green Foundation website and cannot log in. Thanks!
Cheers
KJ

1 Like

Hi, I manage the Socratic Instrumentation, Socratic Electronics, and Modular Electronics Learning Project collections, and when I reset the key I found my password no longer worked. Help!

I used to log in to “login.ibiblio.org” as follows:
%ssh -i ~/.ssh/id_rsa confluence@login.ibiblio.org
i.e., using a private key. But I got an error saying that the host key had changed. So I deleted the ‘offending’ line from “~/.ssh/known_hosts”. Now, when I try to log in, ibiblio asks me for a password. But I never used to need a password; instead, I logged in using a private key. Please help.

Hi, I reinstalled WinSCP and get new key from your server (ssh-rsa 2048 nihOmw…) but I can’t log as demidov. I get “access denied” with my password.

I manage TDL collection and connect via sftp://tdl@login.ibiblio.org/export/sunsite/users/tdl/tdl and this no longer works even after deleting my hosts file.

Hello - replying to your helpdesk ticket about this.

Try logging into login2 with your current credentials, let me know if that doesn’t work for you.

No, that doesn’t work either. It asks me for “confluence@login2.ibiblio.org’s password”.

Either I’ll need to get a password (for “confluence@login.ibiblio.org” and/or “confluence@login2.ibiblio.org”), or else I’ll need to set up a(nother?) public-private key pair for access. But I’ve forgotten how to do this.

Try logging in to login2.ibiblio.org. Let me know if that doesn’t work.

try logging in to login2 - if that doesn’t work, let me know.

No, I can’t log in (to either site), because I don’t have a password. I used to be able to log in (to “login.ibiblio.org”) using a public/private key pair, but I can’t get that to work anymore, because of your servers’ key fingerprints changing.

Probably the simplest way to solve this is for you to just send me (by private message, of course) a password for the “confluence” user. (I’ll change the password after I’ve logged in for the first time.)

Ok - I’ll respond to the help-desk ticket about this.

Yes, that worked, thanks!

1 Like

Hi, I manage the NC Mooshine collection, and I can’t seem to log in now. Please help.

Thank you,

Eric

Hello, I manage the Black Lab Linux site and I cannot log in at this time

Thank you very much Sarah. All works now.

1 Like

Login using public/private key pair seems to be working again. Thanks for whatever you did to fix this :slight_smile:

1 Like

Dear Sir, We have been maintaining www.ibiblio.org/ram/ spiritual site (Thankful to Prof. Jones Paul and Ibiblio Team) but since yesterday, we are not able to login using login.metalab.unc.edu When ever we are trying to do FTP using SSH Secure File Transfer, it is on asking keep asking password. again and again. Kindly suggest.